当前位置:Nanlon > 建站相关 > 正文

记录一次网站环境升级失败的过程

Tips:本文最后更新于2020-04-06 12:29:34,某些文章具有时效性,若有错误或已失效,请在下方留言或联系Nanlon

最近升级了 WordPress 5.4,它推荐的 PHP 版本为 PHP 7.3 或更高版本,于是想着升级一下服务器环境,结果踩坑了!

记录一次网站环境升级失败的过程

先说一下我的服务器配置:

阿里云 ECS:1H2G (T5 实例,SWAP:2GB)
PHP 版本:7.2
MySQL:5.7

1、CentOS 7 升级 CentOS 8

终端使用 dnf 更新安装 CentOS 8,期间频繁报错,最终以失败告终!

2、更换系统盘 安装 CentOS 8

在编译安装(LNMP一键安装包 V1.7)MySQL 8.0 时中途卡死,试了三次均无果。可能我的服务器配置低了,官方要求的最低内存不应小于2GB,虽然符合最低标准,但实际环境中编译时还是不够的。

3、换回 CentOS 7.7

编译安装 LNMP一键安装包 V1.6,PHP 版本 7.3,MySQL 版本 5.7,顺利完成!

恢复原网站数据,又回到原点来了,呜呜呜!

最后,不建议配置太低的服务器追新,新版本的系统和软件环境对配置的要求相应的也会更高!

感觉很棒!可以赞赏支持我哟~

赞(0) 打赏
作者保留所有权,侵删请联系,转载请注明: » Nanlon » 记录一次网站环境升级失败的过程

评论抢沙发